TCoin TCN Deposits and Withdrawals
Incident Report for Trade by trade
Resolved
Withdrawals and Deposits of TCN are reopened. Be careful of not sending TCN to a wallet.tcoin.eu for now as we are experiencing some issues with it.
Posted over 1 year ago. Mar 20, 2018 - 21:39 UTC
Investigating
We are facing an issue with Tcoin TCN deposits and withdrawals. We had to currently block them until the issue is resolved.
Posted over 1 year ago. Mar 20, 2018 - 17:38 UTC