Maintenance delay
Incident Report for Trade by trade
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 06, 2018 - 21:21 UTC
Identified
We are performing an update of the platform to improve speed and security. We ran into a problem of servers and we expect everything to come back to normal in the next minutes.
Posted almost 2 years ago. Jan 06, 2018 - 19:09 UTC