Maintenance
Incident Report for Trade by trade
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 22, 2018 - 07:14 UTC
Identified
We are in maintenance for a couple of hours solving an issue that appeared recently.

Expected finish time around 10am GMT
Posted over 1 year ago. Jun 21, 2018 - 21:43 UTC
This incident affected: Platform.