Performance improvement
Incident Report for Trade by trade
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 08, 2018 - 20:02 UTC
Update
We are still monitoring the results and additional delay of 3 hours is expected.
Posted over 1 year ago. Jan 08, 2018 - 13:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Jan 08, 2018 - 09:50 UTC
Identified
Some additional improvements on the performance will take place 06 Jan 2018 between 6AM and 12AM GMT.
Posted over 1 year ago. Jan 07, 2018 - 22:50 UTC